By continuing to use this site, you agree to the Terms of Service of this website, including usage of cookies.

OK, Don't show this again

An advanced fly plugin for PMMP!
version 3.8.3
Approved
Direct Download How to install?
Switch version
3866 Downloads / 8890 Total
8 Reviews
Plugin Description §

FlyPE

FlyPE

Latest version

FlyPE is a fly plugin for PocketMine-MP that allows you to fly in survival mode when you run the fly command! There are many different features in the plugin that makes it special, and you should check them out!

This plugin would be useful for big or skyblock servers that would not like players to use fly in PVP zones or the hub. And if you would like players to pay for toggling flight, there's an option for that!

This plugin is in English and there are even customizable messages for those that want to use other languages. And there are also fly settings to prevent players from doing different actions while in flight mode.

Thanks to the Contributors for helping FlyPE!

Note: If you are updating from v2 to v3, please delete your old configuration or update it.

Features

Features

The list below state the features of FlyPE. If you have any suggestions for the plugin, feel free to let me know here and I would look at it as soon as possible!

  • [✔️] Blacklist selected worlds from flying
  • [✔️] Whitelist selected worlds from flying
  • [✔️] An option to disable fly when hurt by a player
  • [✔️] An option to disable fly after joining if fly is on
  • [✔️] Blocked players in creative from toggling fly
  • [✔️] Able to toggle fly for other players
  • [✔️] An option to allow a fly UI to toggle flight
  • [✔️] An option to enable buying of fly
  • [✔️] Temporal Flight Time
  • [✔️] Ability to Change UI Texts
  • [✔️] Many fly permissions
  • [✔️] Customisable messages
  • [✔️] Configurable Flight Speed
  • [✔️] Flight Particles
  • [✔️] Flight Effects
  • [✔️] Creative Mode Settings
  • [✔️] Plugin Integration
  • [✔️] Toggle Sounds

Permissions

Permissions

Permissions required for players to use the command, /fly.

Permission Description Default
flype.command Allows player to run the fly command OP
flype.command.others Allows player to run the fly command on others OP
flype.command.particles Allows player to have the flight particles OP
flype.command.effects Allows player to have the flight effects OP
flype.command.flightspeed Allows player to have the flight speed modification OP
flype.command.bypass Allows player to bypass checks when switching to a different world false

Installation

Installation

If you are new or need help with installing the plugin, here's a step-by-step guide on how to do that!

  1. Select the latest version of the plugin, and download the latest phar by pressing on Direct Download on the top left corner of your screen.

  2. Open your server's plugins folder and put the phar into your server's plugins folder. Make sure to also check if you're putting it into the right server.

  3. Ensure that you have the permission to use the fly command (flype.command), restart your server and type the command, /fly ingame to toggle flight!

That's all you have to do to install the plugin. You may also want to check out the config in your plugins data folder as there are many features for you to explore!

Requirements

Requirements

The list below state the requirements of FlyPE!

  • A PocketMine-MP Server (REQUIRED)
  • EconomyAPI (OPTIONAL)

Support

Support

If you have any issues with the plugin, or have any suggestions for the plugin, or have any questions, feel free to let me know here and I would look at it as soon as possible!

GitHub issues GitHub closed issues

Configuration

Configuration

These are the config versions of FlyPE. To find your config version, open the config.yml file in FlyPE's plugin data folder and find the header, "VERSION".

  • Config v1 You can find the config file for v1.0.0, v1.0.1 here!

  • Config v2 You can find the config file for v2.0.0, v2.0.1, v2.0.2, v2.0.3 here!

  • Config v3 You can find the config file for v3.3.2, v3.3.3, v3.3.4, v3.7.0, 3.8.3 here!

What's new §
  • [3.8.3] Multiple Additions & Temp Fly
    Added Plugin Support for VanishV2 and SimpleLay to make it more Moderator and Player Friendly
    Added Flight Data Handling
    Added Temp Flight with the new Data Manager
    Added Incompatibility & File Checks
    Added Configurable Creative Mode Settings
    Added the Ability to Toggle Level Change Restriction Messages
    Added a Configurable Level Change Message for Unrestricted Worlds
    Refactored the Gamemode Creative Checks
    Refactored combat-fly-disable Checks (fixes it not working too)
    Set enable-fly-sound to true by Default
    Moved onLevelChange() Checks to Util
    Removed an Unused Import
    Updated Copyright to 2021
  • [3.3.4] Bug Fix
    Fixed disablePlugin() called twice onEnable() (thanks @Kygekraqmak)
    Fixed details in README.md
  • Full Rewrite (#16)
    Improved Code Formatting
    Implemented the Ability to Change UI Texts (#10)
    Implemented Particles (#8)
    Implemented Configurable Flight Speed
    Implemented Configurable Flight Effects
    Implemented Configurable Toggle Sounds
    Resolved Invalid Player Error (#13)
    Added More Tags to Messages
  • Fixed a crash that nobody told me about 🤦‍♂️
  • Fixed #9
  • Finally got the icon working
  • New update and config version
  • Added JackMD's UpdateNotifier <3
  • Added customisable messages
  • Added 5 new fly settings
  • Cleaned and shortened stuff
  • Set bypass permission default to false
  • Fixed #5

MrBlasyMSK
using v3.8.3
28 Aug 21
WolFoxHD
using v3.8.3
17 Jan 21
Gg
cosmicnebula200
Outdated
using v3.3.4
07 Jan 21
AGTHARN
14 Jan 21
Thanks!
KygekDev
Outdated
using v3.3.4
28 Dec 20
Great plugin, used it when I was a server owner!
AGTHARN
28 Dec 20
Thank you!
Altamash347
Outdated
using v2.0.3
26 Aug 20
Please Add a Soft Depend feature for PurePerms and add something in Config.yml which will only allow a specific Group of PurePerms to fly because PurePerms /setgperm command is not working I dont know why so please add this So I give it 5 Stars
AGTHARN
28 Aug 20
Hi, thanks for using the plugin. I will take your suggestion into consideration. However, I did not make or create any parts of the PurePerms plugin. Please create an issue on their github page if you encounter any problems with the PurePerms plugim. Thanks!
IceCruelStuff
Outdated
using v2.0.3
29 Jun 20
Very good plugin
AGTHARN
06 Jul 20
Thank you! Feel free to share some ideas!
EarthCraftOfficial
Outdated
using v2.0.0
01 Jun 20
Good Plugin! Used it on my Server and Worked Perfectly, Thank you!
AGTHARN
01 Jun 20
Thanks! <33
ShurumbaPR
Outdated
using v1.0.1
31 May 20
This is a really awesome plugin, I've used it in my new server and it works A-OK!!! :)
AGTHARN
31 May 20
That's great to know! If you have any suggestions, feel free to let me know! <3

Reply to review by :

Supported API versions
3.0.0
->
3.25.0
Dependencies
EconomyAPI 5.7.2
Optional
View Plugin
PurePerms 1.4.3
Optional
View Plugin
VanishV2 1.15
Optional
View Plugin
SimpleLay 1.1.0
Optional
View Plugin
Producers §
  • Collaborators:
    • @HyperFlareMC
  • Contributors:
    • @KygekDev
License §
Categories:
General
Admin Tools
Fun
Miscellaneous
Permissions
Permissions
Commands

You can leave one review per plugin release, and delete or update your review at any time

Loading...