By continuing to use this site, you agree to the Terms of Service of this website, including usage of cookies.

OK, Don't show this again

A pocketmine plugin that allows players to brag about their items.
version 1.2.0
Approved
Direct Download How to install?
Switch version
50 Downloads / 258 Total
1 Review
Plugin Description §

ItemBrag

A pocketmine plugin that allows players to brag about their items.

How to use

  1. Download the phar from poggit.

  2. Upload to your servers 'plugin' folder.

  3. Restart your server.

Commands

/brag:

Hold the item you wish to brag to other players, run /brag and the items name will appear in chat along with its count. Any enchants will appear (including enchants from piggy ces) aslong as you have the permissions which can be found in the permissions section of the plugin.

Config

Set this to true if you wish to disable /brag without uninstalling the plugin

brag-disabled: false

Message sent to player if brag-feature-disabled is set to true

brag-feature-disabled-message: "§cThis command is currently disabled!"

Message sent to player if they run /brag and their hand is empty

message-sent-to-player-when-hand-is-empty: "§cYou must hold an item while running this command!"

Message sent to player if they lack the permissions to brag

no-perms-message: "§cYou do not have permission to use this command!"

Message sent to player if they lack the permission to brag about items with enchants on

no-perms-message-enchants: "§cYou do not have permission to brag about items with enchants on!"

Permissions

permissions:

itembrag.brag.allow:

description: Allows players to brag using /brag.
default: op

itembrag.allow.enchants:

description: Allows players to brag about items with enchants on.
default: op

Plans

  • Adding a configurable command delay as I know this will be requested.
  • Maybe a GUI for looking at items players are bragging about.
  • Correct colour formats for rarities of enchants from piggy custom enchants.

Support

If you need any assistance or have suggestions DM me on discord TPE#3107.

Keep in mind you must have pocketmine 3.14.0 in order to use this plugin.

What's new §
  • API bump for 1.16.0
  • Added support for enchants shockwave, fireworks, headless and iceaspect.
  • Pocketmine version required is 3.14.0

ItzFabb-uwu
using v1.3.0
10 Aug 20
TPEimperialPE
10 Aug 20
Thanks :D

Reply to review by :

Supported API versions
3.14.0
->
3.15.0
Dependencies
PiggyCustomEnchants 2.2.0
Optional
View Plugin
License §
Categories:
General
Admin Tools
Informational
Chat-Related
Fun
Miscellaneous
Permissions
Permissions
Commands

You can leave one review per plugin release, and delete or update your review at any time

Loading...