By continuing to use this site, you agree to the Terms of Service of this website, including usage of cookies.

OK, Don't show this again

A PocketMine-MP plugin which let's you whitelist/blacklist specific commands on specific worlds.
version 2.1.1
Approved
Direct Download How to install?
Switch version
33 Downloads / 417 Total
10 Reviews
Plugin Description §

Overview

A PocketMine-MP plugin which let's you whitelist/blacklist specific commands on specific worlds. This is a very flexible plugin as you can easily give/restrict groups/users via permissions.

KNOWN BUG: If there is only 1 world a command can work in, it will not get blocked. So add at least another world (which can be existing or non-existing) to keep the plugin working.

NOTE: This plugin cannot block commands that has been overridden by another plugin. (Ex. MadCommands)

Config.yml

Set up the commands and the whitelisted/blacklisted world(s) on which the specific command will work/blocked on.

  • command1:
    • "world1"
    • "world2"
  • command2:
    • "world3"

Permissions

Operators will be able to bypass this restriction by default. Users with levellimiter.bypass can bypass this restriction. If you want to grant access to a group/user to bypass the restriction on a specific world, add levellimiter.bypass.<world>.

<world> denotes the world name.

Example:

  • levellimiter.bypass.flat grants the user/group to bypass restrictions on flat world.

If you want to grant access to a group/user a specific command on a specific world, add levellimiter.bypass.<world>.<command>. Example:

  • levellimiter.bypass.flat.pay grants the user/group to use the /pay command on flat world.

Contact

  • Discord: MCA7#1245
What's new §
  • Added blacklist mode
  • Added config versioning system (please delete the old config.yml file for the plugin to work)
  • Optimized code
  • Other minor changes
  • Minor bug fixes
  • Added PM4 support
  • Added a feature to change prefix and block-message in config. (Please delete the old config.yml before you update the plugin).
  • Please read about the KNOWN BUG in overview.
  • Fixed major bugs thanks to ErikPDev's PR.
    • Major bugs as in commands not been blocked due to arguments.
  • Merge pull request #4 from ErikPDev/main
  • Minor bug fixes.

KuaterCraft
Outdated
using v2.1.1
29 Jul 22
I really needed this plugin its damn good for the server but whenever i execute command that is not executable by deoped player it "in_array(): Argument #2 ($haystack) must be of type array, bool given"
MCPEAbdu77
30 Jul 22
Use dev build #39
GamerMJay
Outdated
using v2.0.0
12 Jun 22
MrBlasyMSK
Outdated
using v2.0.0
09 May 22
NoNeim1
Outdated
using v1.3.0
08 Aug 21
ErrorException: "Array to string conversion" (EXCEPTION) in "plugins/LevelLimiter.phar/src/MCA7/LevelLimiter/Main" at line 37
MCPEAbdu77
08 Aug 21
Message me on discord with the issue, MCA7#1245.
BishalGamer
Outdated
using v1.3.0
05 Aug 21
Best Plugin Ever Works On All Mc Version ❤️
ErikPDev
Outdated
using v1.2.0
24 May 21
Works!
MCPEAbdu77
01 Aug 21
thanks for the contribution!
JoshuaPHYT
Outdated
using v1.1.0
27 Apr 21
ZZWILLIAMXXTrue
Outdated
using v1.1.0
25 Apr 21
Yay better config!
CkgCam
Outdated
using v1.0.0
17 Apr 21
Damn bro this is actually so sick 😂
MCPEAbdu77
03 Jun 21
Thanks
UnEnanoMas
Outdated
using v1.0.0
16 Apr 21
This is better than winning the lottery :)

Reply to review by :

/ 5
Supported API versions
4.0.0
->
4.7.0
Producers §
  • Collaborators:
    • @MCPEAbdu77
  • Contributors:
    • @ErikPDev
License §
Categories:
Chat-Related
Admin Tools
Mechanics
Miscellaneous

You can leave one review per plugin release, and delete or update your review at any time

/ 5
Loading...