By continuing to use this site, you agree to the Terms of Service of this website, including usage of cookies.

OK, Don't show this again

A plugin that allows you to manage certain events in certain regions of the world.
version 1.1.1
Approved
Direct Download How to install?
Switch version
198 Downloads / 212 Total
2 Reviews
Plugin Description §

General

RegionProtect is temporarily called a protected region? Once the designated region is protected, the player will no longer worry about the features in a world, and when entering that region, it will display the title to let the player know the characteristics of the region there.

State API Downloads Total Downloads Lint

Features

  • Show title when entering region.
  • Allow or disallow pvp in the region.
  • Allow or disallow block breaking in the region.
  • Allow or disallow placing in the region.
  • Allow or disallow touching (interaction) in the region.

How to use?

  1. /region wand - Take the wooden ax and choose the vector.
  2. Select the start and end points to set up the frameset for the region.
  3. /region create - You are required to fill in information to create an region.
  4. /region edit <regionName> - Edit the region the you wants.

Permissions

Permission Description
regionprotect.command.use Basic permission to be able to use the Region feature.
regionprotect.interactive.use Permission is allowed to interact in the forbidden region. (Developing)

Futures

  • [ ] Notification type: subtitle, mess, popup, tip.
  • [ ] Sound.
  • [ ] Etc.

Configs

---
# If true, show title when player enters an region.
show-title: true

# Warning message are sent to players when their actions are blocked.
warning-message: "Can't do this in the standing region."

# Timeout between warning message in seconds.
waiting-message: 3

# Operator players can still act in the forbidden region.
interactive-operator: true
...

Contacts

You can contact me directly through the platforms listed below

License

GNU General Public License v3.0

What's new §
  • Bump version to 1.1.1
    • Fixed Cannot use non-existing permission "region.command.use"

skyss0fly
Outdated
using v1.1.0
26 Jun 22
needs serious fixing, cant even start server as one of the permissions doesnt exist and causes server to crash. once that gets fixed, ill be sure to edit my review and use this plugin!
DavidGlitch04
Outdated
using v1.1.0
25 Jun 22

Reply to review by :

/ 5
Supported API versions
4.0.0
->
4.7.0
Producers §
  • Collaborators:
    • @kaidoMC
  • Contributors:
    • @NhanAZ
License §
Categories:
General

You can leave one review per plugin release, and delete or update your review at any time

/ 5
Loading...