By continuing to use this site, you agree to the Terms of Service of this website, including usage of cookies.

OK, Don't show this again

Easy creation of NPCs!
version 1.5.2
Approved
Direct Download How to install?
Switch version
14183 Downloads / 88888 Total
84 Reviews
Plugin Description §

Slapper

The NPC plugin for PocketMine https://discord.gg/n4hANRh

This plugin is designed for PocketMine-MP only and we do not support any other variations, forks or spoons. Compatibility with unofficial variants can occasionally be found, but do not expect support if you are using anything other than PocketMine-MP.

Official addons:

What's new §
  • MCPE 1.13/1.14 release support
  • fix import casing
  • remove useless return & break statements
  • MCPE 1.12.0 support
  • {color} and {line} are now supported when setting slapper nametags
  • Fixed MagmaCube spawning
  • Fixed error on /slapper create with no arguments
  • Stop Slapper motions, fixes #176 (#186)
  • fix #175 slapper head rotation broken since MCPE 1.5

Updated to support MCPE 1.5+

Added SlapperTrait, cut down on duplicated code (#144)
Added some typehints
Disabled all movement for Slapper entities
Enabled strict_types
Fixed placeholders not being translated sometimes, closes #139
Made name tags always visible, fixes #95
Permission and formatting cleanup to commands
Reformatted everything
Update ISSUE_TEMPLATE.md
fix compatibility with latest PM master
updates for PocketMine-MP 3.0.0

  • SlapperHuman: fixed updatePlayerListData() parameters
  • Use built-in API for creating base NBT
  • fixed choking on null height/width properties, closes #143
  • updates for ALPHA12 release
  • Fixed slapper setting hand item not updating to viewers
  • fix for commands not working for playernames containing spaces (#111)
  • compatibility with API 3.0.0-ALPHA11

Removed slapper.seeId
Updated for MCPE 1.2 (ALPHA8)
Added more entities

Initial version
Initial version

KygekDev
using v1.6.1
28 Feb 21
To use this plugin, you need to change `mcpe-protocol` in plugin.yml by converting the plugin from PHAR. You can also remove `mcpe-protocol` if you want the plugin to load in future versions.
HyperEnte
using v1.6.1
24 Feb 21
To the people that don't get it: The protocol is useful when pocketmine changes entities. If you don't want it remove it yourself, it's not that hard
Endermanbugzjfc
using v1.6.1
21 Feb 21
lukas-studio-tv
using v1.6.1
21 Feb 21
JUST. REMOVE. THE. MCPE PROTOCOL THINGY COMPLETLY! It isnt that hard!! And it will work in every verzion then. And no, it dosent break the compatibility of the plugin - it works completly fine!
FriendlySpiderz
using v1.6.1
15 Feb 21
Update protocol to 1.16.201 please!
SOF3
Staff
using v1.6.1
24 Jan 21
ImNotYourDev
using v1.6.1
14 Jan 21
ItzLuis
using v1.6.1
08 Jan 21
Could you please update this?
UltimateSppy765
using v1.6.1
29 Dec 20
When I run server, it faila to load plugin and says Incompatible Network Protocol Version. I'm using Pmmp 3.17.2. What shall I do?
lnibzleBOT
using v1.6.1
21 Dec 20
x
RDrudra
using v1.6.1
21 Dec 20
Plzz update 1.16.201
Furryjaki1992
using v1.6.1
20 Dec 20
pls update 1.16.200
Shadowboy8812
using v1.6.1
08 Dec 20
Thanks for making this! Best plugin in poggit, but plz update soon!
JustZers
using v1.6.1
08 Dec 20
update pls
Ignaciox
using v1.6.1
24 Nov 20
Awesome plugin (at the time of writing it's outdated but it just requires a protocol change that you can just do yourself in the plugin.yml)
AimanIlyasM
using v1.6.1
22 Nov 20
dragonkid608
using v1.6.1
22 Nov 20
fantastic! but it's out-dated support for 3.16.0
ItzFabb-uwu
using v1.6.1
18 Sep 20
I cant do anything idk wa de hell is happend but also there is a problem when u add the command to a slapper the commabd is dont work what da vack
ninjaredfirehot
using v1.6.1
18 Sep 20
There are a few miner bugs, but would greatly recommend!
karizmahh
using v1.6.1
02 Sep 20
brokiem
using v1.6.1
19 Aug 20
snailoman
using v1.6.1
13 Aug 20
This is the plugin that every server need
ZZWILLIAMXXTrue
using v1.6.1
13 Aug 20
Furryjaki1992
using v1.6.0
07 Aug 20
DimBis
using v1.6.0
30 Jul 20
So smt like ``` Hi ``` Hello @everyone
jsonfromstatefarm
using v1.6.0
26 Jul 20
DevInfoMCPE
using v1.6.0
19 Jul 20
sometimes when i restart my server the commands on the slapper gets removed please fix this I am using API version 3.14.2 MCBE/MCPE 1.16.0 and using latest build of Slapper Plugin
TowerFallGaming
using v1.6.0
06 Jul 20
Testing but think it's good
ReviewTimeeeeeee
using v1.5.30
03 Jul 20
This is a great plugin but pleaseseeeeeeee update because I can't edit the yml
FireWolf153
using v1.5.30
02 Jul 20
Guys stop begging him to update. Just update the protocol version yourself in the plugin.yml file. (The protocol for 1.16 is 407)
Radledazzler
using v1.5.30
01 Jul 20
Great plugin I have been using it for a long time :) but PLEEAAASEE update to 1.16 I need it for my serverrr
IronHead43
using v1.5.30
28 Jun 20
Amazing plugin! If you need slappers download this but pls update to new update
LeyKeyDev
using v1.5.30
26 Jun 20
Update to 1.16 pls, thx lol
BambankFx
using v1.5.30
26 Jun 20
Update to 1.16 please
Minenblock
using v1.5.30
10 Jun 20
The best Plugin.
yoloxd1140
using v1.5.20-uhappynow
20 May 20
Best
GamingJedrickYT
using v1.5.20-uhappynow
12 May 20
were really greatful thanks!
CtrlAltTr0ll
using v1.5.20-uhappynow
06 May 20
perfect thank you!!! now can you update SlapperPlus? lol please?
JJBirdmanYT
using v1.5.20-uhappynow
06 May 20
We happy now lol! Thanks!
GoldenGorilla123
using v1.5.20-uhappynow
05 May 20
Thank you so much for updating this plugin, it's the best plugin for servers
DerpCarft
using v1.5.20-uhappynow
04 May 20
Yes finnally you updated!
Electricshockej
using v1.5.2
02 May 20
Pls Update i really like this plugin
XDslapper
using v1.5.2
26 Apr 20
Hello, i love this plugin...but...there is a problem... 1000+ peoples likes to update...I too...I dont know why u not updating...but...PLEASE...Its 4 months of your last version... Thanks
TroniiX915
using v1.5.2
25 Apr 20
Please actulization for 1.14.60 network protocols missing :/
GamingJedrickYT
using v1.5.2
24 Apr 20
Please update to 1.14.60 The plug-in is not working on my server, it's not reading it.. please give us an update
DerpCarft
using v1.5.2
23 Apr 20
Please update!!
Verox001
using v1.5.2
21 Apr 20
Yeah. A nice Plugin. But please update it. Thanks
MHBG
using v1.5.2
21 Apr 20
Good plugins. But please update To pocketMine-MP 1.14.60
LeyKeyDev
using v1.5.2
20 Apr 20
Very good Plugin :) Please update to 1.14.60. Thanks
SkyStudios18
using v1.5.2
18 Apr 20
Love this plugin! please update to 1.14.60. Thanks!

Reply to review by :

Supported API versions
3.9.0
->
3.17.0
Producers §
  • Collaborators:
    • @dktapps
License §
Categories:
General
Admin Tools
Fun
Keywords
Permissions
Manage entities
Permissions
Commands

You can leave one review per plugin release, and delete or update your review at any time

Loading...