By continuing to use this site, you agree to the Terms of Service of this website, including usage of cookies.

OK, Don't show this again

Easy creation of NPCs!
version 1.6.1
Approved
Direct Download How to install?
Switch version
31639 Downloads / 108306 Total
102 Reviews
Plugin Description §

Slapper

The NPC plugin for PocketMine https://discord.gg/n4hANRh

This plugin is designed for PocketMine-MP only and we do not support any other variations, forks or spoons. Compatibility with unofficial variants can occasionally be found, but do not expect support if you are using anything other than PocketMine-MP.

Official addons:

What's new §

MCPE 1.16.20 compatibility

  • Update protocol for PMMP 3.14.0 (MCPE 407) (#262)
  • 1.5.3, support for PM 3.13
  • Protocol 390 for MCPE 1.14.60, PMMP ver 3.12.0 (#237)
    • Added protocol 390 in plugin.yml
  • MCPE 1.13/1.14 release support
  • fix import casing
  • remove useless return & break statements
  • MCPE 1.12.0 support
  • {color} and {line} are now supported when setting slapper nametags
  • Fixed MagmaCube spawning
  • Fixed error on /slapper create with no arguments
  • Stop Slapper motions, fixes #176 (#186)
  • fix #175 slapper head rotation broken since MCPE 1.5

Updated to support MCPE 1.5+

Added SlapperTrait, cut down on duplicated code (#144)
Added some typehints
Disabled all movement for Slapper entities
Enabled strict_types
Fixed placeholders not being translated sometimes, closes #139
Made name tags always visible, fixes #95
Permission and formatting cleanup to commands
Reformatted everything
Update ISSUE_TEMPLATE.md
fix compatibility with latest PM master
updates for PocketMine-MP 3.0.0

  • SlapperHuman: fixed updatePlayerListData() parameters
  • Use built-in API for creating base NBT
  • fixed choking on null height/width properties, closes #143
  • updates for ALPHA12 release
  • Fixed slapper setting hand item not updating to viewers
  • fix for commands not working for playernames containing spaces (#111)
  • compatibility with API 3.0.0-ALPHA11

Removed slapper.seeId
Updated for MCPE 1.2 (ALPHA8)
Added more entities

Initial version
Initial version

rokibot009
using v1.6.2
07 Nov 21
Wow :v
Multiple30
Outdated
using v1.6.1
16 Sep 21
Mi servidor 1.17.10 crashea cuando utilizo /slapper spawn
Lunarelly
Outdated
using v1.6.1
24 Aug 21
who cant fix just use this https://github.com/Lunarelly/Slapper
Andrei12333
Outdated
using v1.6.1
21 Jul 21
The plugins has been fixed by me and I have a direct link for free and I show you how I fixed it https://youtu.be/xGlgR-f44aw
KygekDev
Outdated
using v1.6.1
17 Jul 21
This plugin no longer officially supported by jojoe77777 and it won't work in newer PocketMine-MP versions even though protocol version has been removed or bumped.
BranGamer145
Outdated
using v1.6.1
02 Jun 21
that's why when I install this plugin when I want to /slapper That's even Invalid Command Even though I have installed the plugin Pls Fix Developer🗿🙏
pingggch
Outdated
using v1.6.1
02 Jun 21
Not work
creeperplayer20
Outdated
using v1.6.1
24 May 21
minewaffle
Outdated
using v1.6.1
10 Apr 21
The plugins has been fixed by me and I have a direct link for free and I show you how I fixed it https://youtu.be/xGlgR-f44aw
QUACKYCYBER
Outdated
using v1.6.1
06 Apr 21
Works perfectly on Plugin Version 1.16.2 and minecraft Version 1.16.210
ray346
Outdated
using v1.6.1
30 Mar 21
cooleoooo66
Outdated
using v1.6.1
23 Mar 21
good plugin but the discord link does not work please help I need support
Neonwaltz8
Outdated
using v1.6.1
23 Mar 21
This plugin doesn't work.. and the Discord Invite link doesn't also work.. Help us? please? thanks!
AtomicCityBuild
Outdated
using v1.6.1
14 Mar 21
For everyone: Download the .phar, convert it to a zip (just google "phar to zip" for a converter), open the downloaded zip, open plugin.yml, remove "mcpe-protocol" and all numbers under it completely. Now you just need to save the new plugin.yml in the zip
xXCoolTobiXx
Outdated
using v1.6.1
11 Mar 21
When I install it it says Incompatible network protocol version and there re no Tutorials
HyperEnte
Outdated
using v1.6.1
24 Feb 21
To the people that don't get it: The protocol is useful when pocketmine changes entities. If you don't want it remove it yourself, it's not that hard
Endermanbugzjfc
Outdated
using v1.6.1
21 Feb 21
lukas-studio-tv
Outdated
using v1.6.1
21 Feb 21
JUST. REMOVE. THE. MCPE PROTOCOL THINGY COMPLETLY! It isnt that hard!! And it will work in every verzion then. And no, it dosent break the compatibility of the plugin - it works completly fine!
FriendlySpiderz
Outdated
using v1.6.1
15 Feb 21
Update protocol to 1.16.201 please!
SOF3
Staff Outdated
using v1.6.1
24 Jan 21
ImNotYourDev
Outdated
using v1.6.1
14 Jan 21
ItzLuis
Outdated
using v1.6.1
08 Jan 21
Could you please update this?
UltimateSppy765
Outdated
using v1.6.1
29 Dec 20
When I run server, it faila to load plugin and says Incompatible Network Protocol Version. I'm using Pmmp 3.17.2. What shall I do?
lnibzleBOT
Outdated
using v1.6.1
21 Dec 20
x
RDrudra
Outdated
using v1.6.1
21 Dec 20
Plzz update 1.16.201
Fuzuto
Outdated
using v1.6.1
20 Dec 20
pls update 1.16.200
Shadowboy8812
Outdated
using v1.6.1
08 Dec 20
Thanks for making this! Best plugin in poggit, but plz update soon!
JustZers
Outdated
using v1.6.1
08 Dec 20
update pls
Ignaciox
Outdated
using v1.6.1
24 Nov 20
Awesome plugin (at the time of writing it's outdated but it just requires a protocol change that you can just do yourself in the plugin.yml)
AiminProjects
Outdated
using v1.6.1
22 Nov 20
dragonkid608
Outdated
using v1.6.1
22 Nov 20
fantastic! but it's out-dated support for 3.16.0
ItzFabb-uwu
Outdated
using v1.6.1
18 Sep 20
I cant do anything idk wa de hell is happend but also there is a problem when u add the command to a slapper the commabd is dont work what da vack
ninjaredfirehot
Outdated
using v1.6.1
18 Sep 20
There are a few miner bugs, but would greatly recommend!
karizmahh
Outdated
using v1.6.1
02 Sep 20
brokiem
Outdated
using v1.6.1
19 Aug 20
snailoman
Outdated
using v1.6.1
13 Aug 20
This is the plugin that every server need
ZZWILLIAMXXTrue
Outdated
using v1.6.1
13 Aug 20
Fuzuto
Outdated
using v1.6.0
07 Aug 20
DimBis
Outdated
using v1.6.0
30 Jul 20
So smt like ``` Hi ``` Hello @everyone
jsonfromstatefarm
Outdated
using v1.6.0
26 Jul 20
DevInfoMCPE
Outdated
using v1.6.0
19 Jul 20
sometimes when i restart my server the commands on the slapper gets removed please fix this I am using API version 3.14.2 MCBE/MCPE 1.16.0 and using latest build of Slapper Plugin
TowerFallGaming
Outdated
using v1.6.0
06 Jul 20
Testing but think it's good
ReviewTimeeeeeee
Outdated
using v1.5.30
03 Jul 20
This is a great plugin but pleaseseeeeeeee update because I can't edit the yml
FireWolf153
Outdated
using v1.5.30
02 Jul 20
Guys stop begging him to update. Just update the protocol version yourself in the plugin.yml file. (The protocol for 1.16 is 407)
Radledazzler
Outdated
using v1.5.30
01 Jul 20
Great plugin I have been using it for a long time :) but PLEEAAASEE update to 1.16 I need it for my serverrr
IronHead43
Outdated
using v1.5.30
28 Jun 20
Amazing plugin! If you need slappers download this but pls update to new update
LeyKeyDev
Outdated
using v1.5.30
26 Jun 20
Update to 1.16 pls, thx lol
BambankFx
Outdated
using v1.5.30
26 Jun 20
Update to 1.16 please
Minenblock
Outdated
using v1.5.30
10 Jun 20
The best Plugin.
Aternos137
Outdated
using v1.5.20-uhappynow
19 Mar 21
Can't use on sever Aternos

Reply to review by :

Supported API versions
3.13.0
->
3.25.6
Producers §
  • Collaborators:
    • @Vecnavium
    • @dktapps
    • @jojoe77777
License §

Custom license

View
                   GNU LESSER GENERAL PUBLIC LICENSE
                       Version 3, 29 June 2007

 Copyright (C) 2007 Free Software Foundation, Inc. <http://fsf.org/>
 Everyone is permitted to copy and distribute verbatim copies
 of this license document, but changing it is not allowed.


  This version of the GNU Lesser General Public License incorporates
the terms and conditions of version 3 of the GNU General Public
License, supplemented by the additional permissions listed below.

  0. Additional Definitions.

  As used herein, "this License" refers to version 3 of the GNU Lesser
General Public License, and the "GNU GPL" refers to version 3 of the GNU
General Public License.

  "The Library" refers to a covered work governed by this License,
other than an Application or a Combined Work as defined below.

  An "Application" is any work that makes use of an interface provided
by the Library, but which is not otherwise based on the Library.
Defining a subclass of a class defined by the Library is deemed a mode
of using an interface provided by the Library.

  A "Combined Work" is a work produced by combining or linking an
Application with the Library.  The particular version of the Library
with which the Combined Work was made is also called the "Linked
Version".

  The "Minimal Corresponding Source" for a Combined Work means the
Corresponding Source for the Combined Work, excluding any source code
for portions of the Combined Work that, considered in isolation, are
based on the Application, and not on the Linked Version.

  The "Corresponding Application Code" for a Combined Work means the
object code and/or source code for the Application, including any data
and utility programs needed for reproducing the Combined Work from the
Application, but excluding the System Libraries of the Combined Work.

  1. Exception to Section 3 of the GNU GPL.

  You may convey a covered work under sections 3 and 4 of this License
without being bound by section 3 of the GNU GPL.

  2. Conveying Modified Versions.

  If you modify a copy of the Library, and, in your modifications, a
facility refers to a function or data to be supplied by an Application
that uses the facility (other than as an argument passed when the
facility is invoked), then you may convey a copy of the modified
version:

   a) under this License, provided that you make a good faith effort to
   ensure that, in the event an Application does not supply the
   function or data, the facility still operates, and performs
   whatever part of its purpose remains meaningful, or

   b) under the GNU GPL, with none of the additional permissions of
   this License applicable to that copy.

  3. Object Code Incorporating Material from Library Header Files.

  The object code form of an Application may incorporate material from
a header file that is part of the Library.  You may convey such object
code under terms of your choice, provided that, if the incorporated
material is not limited to numerical parameters, data structure
layouts and accessors, or small macros, inline functions and templates
(ten or fewer lines in length), you do both of the following:

   a) Give prominent notice with each copy of the object code that the
   Library is used in it and that the Library and its use are
   covered by this License.

   b) Accompany the object code with a copy of the GNU GPL and this license
   document.

  4. Combined Works.

  You may convey a Combined Work under terms of your choice that,
taken together, effectively do not restrict modification of the
portions of the Library contained in the Combined Work and reverse
engineering for debugging such modifications, if you also do each of
the following:

   a) Give prominent notice with each copy of the Combined Work that
   the Library is used in it and that the Library and its use are
   covered by this License.

   b) Accompany the Combined Work with a copy of the GNU GPL and this license
   document.

   c) For a Combined Work that displays copyright notices during
   execution, include the copyright notice for the Library among
   these notices, as well as a reference directing the user to the
   copies of the GNU GPL and this license document.

   d) Do one of the following:

       0) Convey the Minimal Corresponding Source under the terms of this
       License, and the Corresponding Application Code in a form
       suitable for, and under terms that permit, the user to
       recombine or relink the Application with a modified version of
       the Linked Version to produce a modified Combined Work, in the
       manner specified by section 6 of the GNU GPL for conveying
       Corresponding Source.

       1) Use a suitable shared library mechanism for linking with the
       Library.  A suitable mechanism is one that (a) uses at run time
       a copy of the Library already present on the user's computer
       system, and (b) will operate properly with a modified version
       of the Library that is interface-compatible with the Linked
       Version.

   e) Provide Installation Information, but only if you would otherwise
   be required to provide such information under section 6 of the
   GNU GPL, and only to the extent that such information is
   necessary to install and execute a modified version of the
   Combined Work produced by recombining or relinking the
   Application with a modified version of the Linked Version. (If
   you use option 4d0, the Installation Information must accompany
   the Minimal Corresponding Source and Corresponding Application
   Code. If you use option 4d1, you must provide the Installation
   Information in the manner specified by section 6 of the GNU GPL
   for conveying Corresponding Source.)

  5. Combined Libraries.

  You may place library facilities that are a work based on the
Library side by side in a single library together with other library
facilities that are not Applications and are not covered by this
License, and convey such a combined library under terms of your
choice, if you do both of the following:

   a) Accompany the combined library with a copy of the same work based
   on the Library, uncombined with any other library facilities,
   conveyed under the terms of this License.

   b) Give prominent notice with the combined library that part of it
   is a work based on the Library, and explaining where to find the
   accompanying uncombined form of the same work.

  6. Revised Versions of the GNU Lesser General Public License.

  The Free Software Foundation may publish revised and/or new versions
of the GNU Lesser General Public License from time to time. Such new
versions will be similar in spirit to the present version, but may
differ in detail to address new problems or concerns.

  Each version is given a distinguishing version number. If the
Library as you received it specifies that a certain numbered version
of the GNU Lesser General Public License "or any later version"
applies to it, you have the option of following the terms and
conditions either of that published version or of any later version
published by the Free Software Foundation. If the Library as you
received it does not specify a version number of the GNU Lesser
General Public License, you may choose any version of the GNU Lesser
General Public License ever published by the Free Software Foundation.

  If the Library as you received it specifies that a proxy can decide
whether future versions of the GNU Lesser General Public License shall
apply, that proxy's public statement of acceptance of any version is
permanent authorization for you to choose that version for the
Library.
Categories:
General
Admin Tools
Mechanics
Miscellaneous
Keywords
Permissions
Manage entities
Permissions
Commands

You can leave one review per plugin release, and delete or update your review at any time

/ 5
Loading...