By continuing to use this site, you agree to the Terms of Service of this website, including usage of cookies.

OK, Don't show this again

A plugin which adds commands to the client's autofill by parsing usage messages
version 1.0.0-beta3
Approved
Direct Download How to install?
Switch version
319 Downloads / 15663 Total
8 Reviews
Plugin Description §

Intro

Discord

EasyCommandAutofill is a plugin which adds commands to the client's autofill system by parsing usage messages. By adding this plugin to your server, all command usages written in the vanilla style will be parsed and sent to the client with autofill enabled.

Features

  • Enables autofill on commands in your server
    • Simple argument support
    • Enum argument support
    • Multiple argument trees
  • Configurable parsing improvements
  • Easy API to create custom overrides

Future Additions

  • Configurable debug highlights
  • Parsing support for pocketmine default usage messages which do not follow vanilla style

About

This plugin was made in my spare time because I was bored. No backstory or anything to follow along with here like in my other plugins' about sections. Maybe next time?

What's new §
  • Added Support for update-able Enums
  • Fixed minor parsing bug
  • Moved event handler to separate class
  • Added config value for debug highlights
  • Always check if the manual override is missing anything
  • Make config look nice
  • Override the override permission setting to make sure client can/cannot see commands
  • Parse arguments without indicators as single-argument enums
  • Resend packets when API is used to change data
  • Updated discord link
  • Added plugin icon
  • Added API for debug commands and added defaults
  • Added config option for taking param names into account for type assignments
  • Stopped adding arguments to commands without args
  • Added highlights to debug commands
  • Make enum names unique for identification
  • Now using events instead of a custom player class
  • Parser improvements
  • Version Bump

zoooos
using v1.0.4
29 Aug 20
zoooos
using v1.0.3
13 Aug 20
please update again for protocol 407
jsonfromstatefarm
using v1.0.3
26 Jul 20
cheeseland-dev
using v1.0.2
28 Jun 20
please update!!
D7oomy1070
using v1.0.1
12 Jun 20
Just Perfect man ! ty
DerDevHD
using v1.0.1
23 Apr 20
really nice and usefull plugin.
skillDev5235
using v1.0.0-beta4
08 Feb 20
Wertzui123
using v1.0.0-beta2
07 Jan 20
Cool plugin!

Reply to review by :

Supported API versions
3.0.0
->
3.15.0
Dependencies
PlayerSelectors 1.0.7
Optional
View Plugin
License §
Categories:
Informational
Educational
Miscellaneous
Permissions
Commands

You can leave one review per plugin release, and delete or update your review at any time

Loading...